| neue Message hinzufügen |

Madeleine 2010-08-25 11:24:46
Lustig, 3 verschiedene Transparenz-Angaben, die alle dasselbe aussagen ...

http://www.w3schools.com/Css/css_image_transparency.asp

"Note: This is not yet a CSS standard. However, it works in all modern browsers, and is a part of the W3C CSS 3 recommendation."

"Firefox uses the property opacity:x for transparency, while IE uses filter:alpha(opacity=x)."

Witzigerweise wird für Opera gar kein Beispiel geliefert, vielleicht wurd's damit gar nicht getestet.
Warum muss die Transparenz für das Ding eigentlich per CSS definiert werden, statt im generierten Bild selbst? Kann php das nicht?

Bei mir funktioniert's gar nicht... quabla 2010-08-24 14:51:56
...ich bekomme aber (egal ob eco aktiviert oder nicht) folgende Fehlermeldung in der Errorkonsole:

CSS - http://www.karopapier.de/css/faulpelz.css
Linked-in stylesheet
Declaration syntax error
Line 8:
   filter: alpha(opacity=30);
  ---------------------------^


anfangen kann ich damit aber nix - da hab ich keinen Plan von :-)

... ultimate 2010-08-23 14:43:54
...zugegeben, optimal ist die Lösung nicht. Wenn das Laden der Seite mal länger dauert wird das Skript ausgeführt, bevor das Bild da ist und wirkt dann leider nicht...

Lösung... ultimate 2010-08-22 15:20:03
Da der deaktivierte Economode ja bekanntlich die Ladezeiten verlängert und den Traffic erhöht , habe ich mal ein bisschen rumexperimentiert und bin dabei auf folgendes gekommen:

- Die Seite scheint soweit OK zu sein, warum Opera 10.60 sie nicht richtig anzeigt kann ich einfach nicht verstehen
- Wenn ich mir den Source-Code der Seite anzeigen lasse und am eigentlichen Problem dem Bild nichts ändere, jedoch z.B. irgendwo einen buchstaben im Text hinzufüge und dann auf "Apply changes" klicke, wird plötzlich auch das Bild richtig angezeigt
- Auch wenn ich wie von OleOJumper beschrieben auf eine andere Seite (z.B. JavaScript-Ansicht) gehe und zurück springe, wird plötzlich das Bild richtig angezeigt

Daraus vermute ich, dass beim Rendern der Seite in Opera irgendwas mit der Reihenfolge der Elemente schiefläuft und der Renderer zu blöde ist das zu lösen.

Ich habe also noch etwas rumexperimentiert und mit Hilfe von Operas Möglichkeit User-JavaScript einzubinden eine Lösung gebastelt, die wie folgt aussieht:

Du musst ein "User-JavaScript-Verzeichnis" bzw. "User JavaScript folder" festlegen und in diesem eine JavaScript-Datei mit dem unten enthaltenen Inhalt anlegen. Diese Datei wird dann beim Laden jeder Seite ausgeführt und behebt, (natürlich nur, wenn es sich um eine Karopapier-Spiel-Seite handelt) das Problem per JavaScript. Witziger Weise muss dafür nur die Quelle des fehlerhaten Bildes neu gesetzt werden auf den Wert, den sie ohnehin schon hatte.

Das ganze geht wie folgt:

1. Öffne die Einstellungen (Menü -> Einstellungen -> Einstellungen oder Menu -> Settings -> Preferences)
2. Öffne den Reiter "Erweitert"/"Advanced"
3. Klicke auf "Inhalte"/"Content"
4. Klicke auf "JavaScript-Optionen"/"JavaScript-Options" (JavaScript muss natürlich aktiviert sein)
5. Wähle hier den Ordner aus, in dem du die JavaScript-Datei anlegen möchtest. Solltest du schon ein Verzeichnis ausgewählt haben, kannst du hier natürlich einfach die Datei hinzufügen.
6. Bestätige die Einstellungen und Schließe das Einstellungsfenster
7. Lege im Ausgewählten Verzeichnis eine JavaScript-Datei (Datei mit Dateiendungs .js) mit folgendem Inhalt an (z.B. karo.js):

if(document.URL.indexOf("http://www.karopapier.de/showmap.php") == 0)
{
window.setTimeout("fix_economode()", 1000);
}

function fix_economode()
{
var img = document.getElementsByTagName("img")[0];
if(img)
{
img.src = img.src;
}
}

8. Aktiviere wieder den Economode

Wenn du jetzt die Spielseite im Economode lädst, sollte mit einer kurzen Verzögerung das Bild mit den Spieler angezeigt werden und du kannst wie gewohnt deine Züge machen!



faulpelz hilft OleOJumper 2010-07-20 16:42:55
also bei mir zeigt der faulpelz schon sinnvolles an! derzeit: mit opera 10.10 + ecomodus

opera 10.60 und faulpelz nobody 2010-07-19 22:39:57
Hi Didi,

also, der opera 10.60 tut immer noch nur mit deaktiviertem economode, und der Faulpelz (allerdings bei meinem firefox) zeigt meistens nur 6 Felder an. Und totaler Quatsch ist es sowieso. Nicht daß ich ihn bräuchte oder normalerweise eingeschaltet hätte, aber ab und zu probiere ich mal, ob sich was verbessert hat. Hat sich nicht.

Daher fahre ich nun doch wieder mit firefox. Dann gibt's wenigstens auch keine Meldungen an Big Brother und komische flattr-buttons ;-)

Gruß,

nobody

Pitty 2010-07-14 10:14:31
Tut der das nicht immer???

OleOJumper 2010-07-13 20:28:25
also wenn ich den ecomode ausschalte werden zwar wieder spieler und zugmöglichkeiten gemalt, dafür zeigt der faulpelz dann totalen quatsch an?!

Link vergessen... ultimate 2010-07-08 11:11:59
...im anderen Thread

Das ist aber auch ein interessantes Phänomen... ultimate 2010-07-08 11:11:41
...

pingelig ultimate 2010-07-07 15:21:36
Irgendwie scheint der besonders pingelig zu sein...

Ich glaube jetzt hat er ein Problem mit usemap=#moves. Wenn ich das in usemap="#moves" ändere klappt es...

Sorry, für die Unannehmlichkeiten

Besser? Didi 2010-07-07 13:11:10

Diese "movestransp.png" is weg, keine Ahnung was das da zu suchen hatte...

Besser?

:)idi

Sorry... ultimate 2010-07-06 15:41:56
... ich dachte du meinst die Browser-Einstellungen

Danke, so geht es erstmal!
Auf die Dauer will ich karopapier aber ja nicht unbedingt mit unnötigem Traffic belasten...

Ähm, doch ... fiete 2010-07-06 11:50:30
Einstellungen > Kartendarstellung > Kartendarstellung Economode ...

bitte was...? ultimate 2010-07-06 11:28:23
Da gibt es keinen Economode

Oder ... fiete 2010-07-06 10:44:16
in den Einstellungen den Economode deaktivieren.

Fehlende Spieler -> Ich kann nicht mehr ziehen... ultimate 2010-07-06 09:59:27
Seit ich seit gestern das neue Opera 10.60 Update installiert habe funktioniert bei mir die Spielansicht nicht mehr richtig. Ich kann die Spieler und ihre Züge sowie meine möglichen Züge nicht mehr sehen!

So kann ich nicht ziehen

Scheinbar kommt die neue Rendering-Engine, die in der Version drin sein soll, mit fetten Teil in dem img-Tag nicht klar (der auch total unkonform gegen alles ist ):

<IMG SRC=imgenerateFG.php?GID=54025&pixel=10&karoborder=1&dummy=33159 usemap=#moves movestrans.png usemap=#moves BORDER=0 style="position: absolute; top:0; left:0; z-index:4">

Sobald ich diese Stelle im Source-Code-Editor entferne und die Änderungen übernehme wird alles richtig dargestellt. (der "usemap=#moves"-Teil ist auch irgendwie doppelt, aber das stört ihn nicht...)

Ich werde zwar jetzt vorrübergehend wohl mal auf den Feuerfuchs umsteigen, es wäre aber super, wenn du das fixen könntest Didi


| neue Message hinzufügen |
| Anfang | Vorherige | Nächste |

Brought to you by Didi

Letzter Satz im Chat:
Yashem (14:57): manchmal bin ich schon froh, dass ich einfach nur ziehe (und selbst das nur sporadisch) und sonst nix mitkriege. dance