| neue Message hinzufügen |

:-) Didi 2005-02-02 23:11:51

Jaja, also ganz soooo hab ich's auch nicht gemacht. Aber die entsprechenden Files und Folders sind eben offen... Wie gesagt, sollte kein Mensch rankommen...

:)idi

Ich bin unkreativ Sparti 2005-02-02 22:40:08
Hey Didi, das mit dem chmod -R 777 war nur ein Scherz!

Hab mich getäuscht... Didi 2005-02-02 13:02:41

In den VirtaulHosts war das SUExecUserGroup gesetzt - aber der Apache und somit PHP (weil als mod konfiguriert) läuft trotzdem als apache-user. Entweder müsste man dann PHP als CGI laufen lassen oder eben den Apache komplett unter dem anderen User laufen lassen.

ABer egal, hab jetzt die bösen rechte weit auf gemacht, jetzt tut's auch.

Ist zwar unter Security-Aspekten fragwürdig - aber es ist ja sozusagen mein eigener Server, nur mein Kumpel ist noch drauf, sonst niemand, also ist auch nix zu befürchten.

Trotzdem danke für die Tipps!

:)idi

SUID/SGID Flags gesetzt? yaba 2005-02-02 12:29:16
Kann es sein, dass die betreffenden Directories ein SUID, bzw. SGID Flag besitzen und von Apache:Apache geowned werden?

Linuxunabhängige Lösung Baltimore 2005-02-02 00:01:44
Probier einfach mal in der php.ini den Safe Mode zu deaktivieren.

Wie ist das Setup? kili 2005-02-01 20:52:05
Wie hast Du denn Den Apachen und die VirtualHosts konfiguriert?

SuExec? rusty 2005-02-01 16:24:15
Das mod_suexec Apache-Modul könnte da vielleicht weiterhelfen, einen Apache 2 hast du ja scheinbar laufen, für 1.3.x gibts dafür irgendwelche CGI-Wrapper. Ich kann da aber nichts aus eigener Erfahrung zu sagen. Als Einstieg für weitere Recherchen vielleicht die folgenenden URLs:

http://httpd.apache.org/docs-2.0/mod/mod_suexec.html
http://faq-php.de/q/q-datei-rechte.html

mfG Andreas

Serverproblem - Apache User Didi 2005-02-01 15:16:58
Hallo Kinners,

jetzt muss ich doch mal die ganzen Unixer und Linuxer hier um Hilfe bitten:

Momentan läuft der httpd für karopapier unter einem eigenen usernamen (nennen wir ihn karo). Sobal ich aber auf Logfiles oder die vorgefertigten Previews der Maps schreiben will, scheint der user der Standarduser apache:apache zu sein.

Weiss jemand, wie/ob man das umkonfigurieren kann und mit php erzeugte files dann auch dem "karo" gehören?

Danke schon mal!

:)idi

| neue Message hinzufügen |
| Anfang | Vorherige | Nächste |

Brought to you by Didi

Letzter Satz im Chat:
Didi (1:48): Ui, alles Gute, ruhige Nächte und große Freude mit Mini-Kev!!